Main Center Display Gone Blank - Ford Focus Electric Forum
FordFocusElectric.com is the premier Ford Focus Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-10-2012, 05:35 PM   #1 (permalink)
Member
 
Join Date: Jul 2011
Location: Virginia
Posts: 76
Default Main Center Display Gone Blank

Copying my post from another Forum, anyone else ever experience this problem?

Trying to connect to my iPad for BT Stereo, I had a couple of days when the big main display would show "connected to iPad", but BT Stereo would not show as available to select from the steering wheel selector menu, although it showed on the big main display, and i could select it on the main display and it showed BT Stereo as selected, but it still did not appear as available on the center-right menu and could not be selected, all the while the main display showed bluetooth "connected to iPad".

I don't know if this flakiness is related, but yesterday morning the main display, the 4-section display in the center of the console, went blank completely. I turned around the block and came home and shut off and turned on again, but the center display wouldn't come on. It drove normally and in fact I could select AM Radio from the steering wheel and it played, so I decided to go ahead to work with it anyway instead of going to my Saturn car. Coming home in the evening it was dark enough so that I could see a little bit of a "glow" on the center console display, but there was no info again.

I tried again this morning to turn things on and off, with and without the Level 2 charger connected, but there is no center display.

I contemplated disconnecting the 12V battery and connecting again, as that may reset something.

Reading Whit's post down the list maybe there is a glitch that can be cleaned up with re-flashing.

Is there any negative to disconnecting the 12V battery and possibly "resetting" the accessories?

Anyone else experience this blanking of the big center main display?
billsblots is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2012, 09:42 PM   #2 (permalink)
Senior Member
 
JeffAnd's Avatar
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 142
Garage
Default

Sounds like the display is having an issue. The display uses touch screen with an LCD display. In order for you to see the display the LCD uses a back light for illlumination. To test the touch interface you will first need to turn off the climate control. The climate control power button can be found in the center console. Now on the LCD display touch along the lower edge towards the right side. This will call up the climate control. Now start touching in different areas on the near the middle 1/3rd of the LCD display. While doing this look at the climate controle display note if it comes on. If it does the display it's self could be bad. Don't worry Fords come with a bumper to bumper 36 month warranty.
JeffAnd is offline   Reply With Quote
Old 11-12-2012, 09:32 AM   #3 (permalink)
Senior Member
 
Join Date: Jun 2011
Posts: 207
Default

I'd find the fuse for the stereo/sync/etc. and pull it, wait a few seconds and put it back in. This reboots the radio. From your description it sounds like the FFE is running at least two version's back of the MFT software. The old version of MFT software could not stream audio from a tablet (when I attempted it on my Focus I had a similar result to yours with the old MFT software).
The "Performance upgrade" that was released in the first quarter of this year added the ability to stream audio from a tablet (yes a tablet: its not just iPads that are affected).

You may want to check with your dealer, or with www.syncmyride.com and see if there is an update available for the FFE.



jmueller065 is offline   Reply With Quote
 
Old 11-12-2012, 02:07 PM   #4 (permalink)
Member
 
Join Date: Jul 2011
Location: Virginia
Posts: 76
Default

thanks for the reminder of the syncmyride software.

the display reappeared last night for some reason.

billsblots is offline   Reply With Quote
Old 11-14-2012, 07:16 PM   #5 (permalink)
Senior Member
 
JeffAnd's Avatar
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 142
Garage
Default

If the display disappears again check to see it the voice commands still work, or any other systems are functional. It's interesting to see if this is display problem only. This may be an intermitant problem, which means it will likely come back. The question is it hardware or a software issue?
JeffAnd is offline   Reply With Quote
Old 11-15-2012, 04:45 PM   #6 (permalink)
Member
 
Join Date: Jun 2012
Posts: 37
Default

Quote:
Originally Posted by JeffAnd View Post
If the display disappears again check to see it the voice commands still work, or any other systems are functional. It's interesting to see if this is display problem only. This may be an intermitant problem, which means it will likely come back. The question is it hardware or a software issue?
Always safe to rule it out as software to start, if nothing happens, then Ford will have to replace it.
Focused is offline   Reply With Quote
Old 11-17-2012, 12:07 PM   #7 (permalink)
Member
 
Join Date: Jul 2011
Location: Virginia
Posts: 76
Default

Hey Jeff, yes while the display was blank the Voice Commands still functioned, as did the radio and all the items on the right side of the steering column window. Oddly, when this display fixed itself, I no longer have a problem with the Bluetooth Stereo unable to appear on the menu as I had before.

NOTE: I cannot get to "Discussions" from the myfordmobile web page? I can see the topics listed but when I click on them the browser just cycles around and around.
billsblots is offline   Reply With Quote
Old 11-17-2012, 02:15 PM   #8 (permalink)
Senior Member
 
JeffAnd's Avatar
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 142
Garage
Default

I hope by this point that you have contacted the dealership. This seems to be isolated to the main display, and because that most other systems seem to be functional. You should be able to take your car to any local Ford dealership to have it serviced. This is because the problem you are having seems to have nothing to do with the electric drive system. But rather has to do with the My Ford Touch system. If a Ford EV certified dealership is in your area you should go their whenever possible.
JeffAnd is offline   Reply With Quote
Old 11-21-2012, 06:31 PM   #9 (permalink)
Member
 
Join Date: Jun 2012
Posts: 37
Default

Quote:
Originally Posted by JeffAnd View Post
I hope by this point that you have contacted the dealership. This seems to be isolated to the main display, and because that most other systems seem to be functional. You should be able to take your car to any local Ford dealership to have it serviced. This is because the problem you are having seems to have nothing to do with the electric drive system. But rather has to do with the My Ford Touch system. If a Ford EV certified dealership is in your area you should go their whenever possible.
Thats exactly it. Dealership is the best place to go for this, tough to say what exactly it is, and were way too early in the game to have a DIY fix.

I think Ford will end up reinstalling the software.
Focused is offline   Reply With Quote
Old 11-22-2012, 03:59 PM   #10 (permalink)
Senior Member
 
JeffAnd's Avatar
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 142
Garage
Default

I have experienced with my vehicle when I first turn on the car, the radio will not display the station name, and song names. Other times the power on off button on the radio will not work, but the voice commands to turn on off the radio still works. Now I do have an I-pod Nano that is plugged in all the time. I was wondering if devices that left plugged into the USB ports could be randomly jazzing up the system during a power up.
JeffAnd is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FFE Instrument cluster energy display explained JeffAnd Ford Focus Electric Owners Forum 0 11-07-2012 08:03 PM
Ford tests the FFE display with customers via a simulation jmueller065 Main Ford Focus Forum 2 08-25-2011 01:39 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 03:52 AM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0 PL2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.